ACMS E2X

従来型EDIから次世代EDIまで、あらゆる企業間商取引をカバーするB2Bサーバ ACMS B2B | ACMS B2B Limited Edition

対象:ACMS B2B V5.2.0

ソフトウェア環境

ACMS B2Bには、JavaVMをサポートするUNIXやLinuxなどの商用サーバーOSに対応した製品とWindowsサーバーOSに限定した製品の2種類があります。

ACMS B2B

JDK Oracle Java SE 8(Oracle Solaris(SPARC),Linux,Windows)
Red Hat OpenJDK 8(Linux)
Amazon Corretto 8(Linux,Windows)
Azul Systems Zulu Enterprise 8(Linux,Windows)
AdoptOpenJDK 8 OpenJ9(Linux,Windows)
AdoptOpenJDK 8 HotSpot(Linux,Windows)
FUJITSU Software Interstage Application Server V12 同梱JDK
※Java 8は、Oracle / SQL Server / MySQL / PostgreSQL / Db2のJDBCドライバが対応しています。(2019年11月時点)
Oracle Java SE 11(Oracle Solaris(SPARC),Linux,Windows)
Red Hat OpenJDK 11(Linux)
Amazon Corretto 11(Linux,Windows)
Azul Systems Zulu Enterprise 11(Linux,Windows)
AdoptOpenJDK 11 OpenJ9(Linux,Windows)
AdoptOpenJDK 11 HotSpot(Linux,Windows)
※Java11は、Oracle / SQL ServerのJDBCドライバが対応しています。(2019年11月時点)
OS Red Hat Enterprise Linux
Microsoft Windows Server
Oracle Solaris(SPARC)※1
Oracle Linux
HPE HP-UX※1
Amazon Linux 2
IBM AIX※1
IBM i※1
DBMS ■オンプレミス
Microsoft SQL Server 2008 SP4
Microsoft SQL Server 2008 R2 SP3
Microsoft SQL Server 2012 SP2 / SP3 / SP4
Microsoft SQL Server 2014 SP1 / SP2 / SP3
Microsoft SQL Server 2016 SP1 / SP2
Microsoft SQL Server 2017
Oracle Database 11.2 / 12.1 / 12.2 / 18c / 19c
IBM Db2 9.5 / 9.7 / 10.5 / 11.1
MySQL 5.5 / 5.6 / 5.7
PostgreSQL 9.0 / 9.1 / 9.2 / 9.3 / 9.4 / 9.5 / 9.6 / 10 / 11 / 12
Symfoware 10.0.0 / 10.1.0 / 11.1.0 / 12.0.0 / 12.1.0 / 12.2.0 / 12.3.0 / 12.4.0
FUJITSU Software Enterprise Postgres 9.5 / 9.6 / 10 / 11
NonStop SQL/MX
IBM i(旧称i5/OS、OS/400)同梱のDb2
IBM Db2 for i 7.1 / 7.2 / 7.3

■クラウド
Amazon RDS for SQL Server
Amazon RDS for Oracle
Amazon RDS for PostgreSQL
Amazon RDS for MySQL
Oracle Database Cloud Service
Oracle MySQL Cloud Service
※各DBMSのバージョンについては、オンプレミスがサポートするバージョンをサポート対象としています。
Amazon Aurora (MySQL互換)
WAS
(Web Application Server)
Tomcat 7.0 / 8.0 / 8.5 / 9.0
TomEE Plume 1.7.4
WebSphere Application Server 7.0 / 8.5 / 9.0
Weblogic Server 10g(10.3) / 11g(10.3) / 12c(12.1) / 12cR2(12.2)
Cosminexus 8.X
Interstage Application Server 10.0.0 / 11.1.0
オプション
ACMS Web/deTrade II
取引先側クライアント環境
■アプレット版
 Internet Explorer 9.0 / 10.0 / 11.0 ※2

■非アプレット版
 Internet Explorer 10.0 / 11.0 ※2
 Microsoft Edge 最新版およびその直前のバージョン(ChromiumベースのEdgeは未サポートです)
 Google Chrome 最新版およびその直前のバージョン
 Mozilla Firefox 最新版およびその直前のバージョン

ブラウザ利用可能なOSはWindowsとなります。
ブラウザ自体のサポートポリシーにつきましては、それぞれのベンダー公式サイト等でご確認ください。

※1 OSメーカーのJDK 8の利用が前提です。

※2 Internet Explorer 10 以降ではデスクトップ版の Internet Explorer を使用していただく必要があります。
OSでサポートされるInternet Explorerの詳細はマイクロソフトのサイトを確認してください。
https://support.microsoft.com/ja-jp/gp/microsoft-internet-explorer

前提事項

ACMS B2Bは、Javaで開発しています。Java実行環境で動作する弊社製品は、表にあるJavaベンダーのLTS(Long Term Support)版JDKに対応します。JDK 9、10、12、13などのNon-LTS版JDKには対応しませんので予めご了承ください。また、各Javaは、64ビット版に限定して対応しています。なお、JDK 8では32ビット版にも対応しています。
OSとJDKの対応状況については、OSまたはJDKのベンダー公式サイトでご確認ください。

注意事項

  1. この動作環境は、最新版でのソフトウェア環境です。ソフトウェアのバージョンの組み合わせによっては、制限が出る場合がございます。詳細につきましては、弊社または販売代理店にお問い合わせください。
  2. プロトコルコンバータは、セイコーソリューションズ社製「UST」と日立ソリューションズ製「PCNV20T」をお使い頂けます。
    ただし、この2つの製品の混在はできませんので予めご了承ください。
  3. Cosminexus上での動作に関しては日立ソリューションズ・クリエイト社へご確認ください。
  4. PostgreSQLまたはMySQLのご使用の際のDBのモジュールは、オープンソースコミュニティが提供するモジュールか、あるいは、無改修のソースでビルドされたモジュールであることが条件となります。
    なお、MySQL 4.0.25 およびPostgreSQL 11より前のバージョンではUNIX系OSのみの対応、MySQL 4.0.25、PostgreSQL 11からは、Windows OSとUNIX系OS双方に対応しています。
  5. 商用データベースのライセンス体系や価格については、各ベンダーにお問い合わせください。

ACMS B2B Limited Edition(LE)

ACMS B2B LEの対応OSは、以下のWindowsサーバーOSに限定しています。

OS
新規インストール時
Windows Server 2008 Standard Edition (SP2以上)
Windows Server 2008 Enterprise Edition (SP2以上)
Windows Server 2008 Standard x64 Edition (SP2以上)
Windows Server 2008 Enterprise x64 Edition (SP2以上)
Windows Server 2008 R2 Standard Edition (SP1以上)
Windows Server 2008 R2 Enterprise Edition (SP1以上)
Windows Server 2012 Datacenter Edition
Windows Server 2012 Standard Edition
Windows Server 2012 R2 Datacenter
Windows Server 2012 R2 Standard
Windows Server 2016 Datacenter
Windows Server 2016 Standard
Windows Server 2019 Datacenter
Windows Server 2019 Standard
OS
アップグレード時
Windows Server 2008 Standard Edition (推奨:SP2)
Windows Server 2008 Enterprise Edition (推奨:SP2)
Windows Server 2008 Standard x64 Edition (推奨:SP2)
Windows Server 2008 Enterprise x64 Edition (推奨:SP2)
Windows Server 2008 R2 Standard Edition (推奨:SP1)
Windows Server 2008 R2 Enterprise Edition (推奨:SP1)
Windows Server 2012 Datacenter Edition
Windows Server 2012 Standard Edition
Windows Server 2012 R2 Datacenter
Windows Server 2012 R2 Standard
Windows Server 2016 Datacenter
Windows Server 2016 Standard
Windows Server 2019 Datacenter
Windows Server 2019 Standard
オプション
ACMS Web/deTrade II
取引先側クライアント環境
■アプレット版
 Internet Explorer 9.0 / 10.0 / 11.0 ※1

■非アプレット版
 Internet Explorer 10.0 / 11.0 ※1
 Microsoft Edge 最新の安定バージョン(ChromiumベースのEdgeは未サポートです)
 Google Chrome 最新の安定バージョン
 Mozilla Firefox 最新の安定バージョン

ブラウザ利用可能なOSはWindowsとなります。
ブラウザ自体のサポートポリシーにつきましては、それぞれのベンダー公式サイト等でご確認ください。

※1 Internet Explorer 10 以降ではデスクトップ版の Internet Explorer を使用していただく必要があります。
OSでサポートされるInternet Explorerの詳細はマイクロソフトのサイトを確認してください。
https://support.microsoft.com/ja-jp/gp/microsoft-internet-explorer

注意事項

  1. ACMS B2B LEで利用できるDBは、製品に同梱のSQL Server Expressです。
  2. ACMS B2B LEは、物理環境・仮想化環境のいずれにおいても、無停止(FT)環境やHAクラスタ環境、ライブ・マイグレーション機能などを使って冗長化された環境では利用できません。

Java実行環境の有償サポートの必要性について

弊社製品のJava実行環境の有償サポートにおけるサポート・ポリシーについては、こちらを参照ください。


仮想化環境でのサポートについて

弊社製品の仮想化環境におけるサポートポリシーについては、こちらを参照ください。

ハードウェア環境

最小メモリ 1GB以上
最小ディスク 150MB以上(本体のみ)

英語版

ACMS B2Bでは、英語版もご用意しています。英語版のご利用に際しては、英語版OSをご用意ください。

クラウド環境

  • amazon web services / Partner Network
  • Microsoft Azure
  • FUJITSU Cloud Service for OSS
  • IIJ GIO

クラウド環境のサポートについて

弊社製品のクラウド環境におけるサポートポリシーについては、こちらを参照ください。

連携ソリューション

  • FUJITSU Software Partner

流通BMS対応検証済証明書

  • INTEC